Problem

While migrating a user to Office 365 or Exchange using Cloudiway, you see the following error : “The SMTP address has no mailbox associated with it”.

Cause

The target is incorrectly configured.
If the target is Office 365, either the account does not exist or no Exchange license is assigned to it (in this case, the account exists but no mailbox has been created for it).

Resolution

Create the user and assign an Exchange license.