Problem

During a file migration to OneDrive, the migration fails with the following error message:
Start() Error for user@company.com : GetClientContext : Second Try Failed : https://tenant-my.sharepoint.com/personal/user_company_com : The remote server returned an error: (403) Forbidden.

Cause

The migration account doesn’t have the permissions to write to the target OneDrive.

Resolution

Run the preprocessing task on the user.
The preprocessing will create (provision) the OneDrive profile of the user if it doesn’t exist and will set the permissions to the migration account defined in the OneDrive connector.

Also, during your testing with the trial license, you can set the permissions manually.
http://kb.cloudiway.com/manually-set-permissions-for-an-administrator-account-in-onedrive/